
Objective 4.00 
Apply procedures for Web authoring using Adobe 
Dreamweaver CC.



FILE NAME CONVENTIONS
o File and folder names in websites should 

never contain spaces or symbols.
o Most file and folder names end up as part of 

a web page's URL, so keep them short, but 
meaningful. 

o Using all lowercase letters for file and folder 
names avoids problems with files not being 
found. NO UPPERCASE.

o Home page should always be named 
index.html.
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ROOT FOLDER
o A central location of storage 

for every file involved in 
designing a website; allows 
the website to be moved 
from computer to computer.

o First step in creating 
website, should be to 
define the site which 
requires the following:
• Name the website
• Choose local folder (root 

folder)
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DEFINE SITE
o In Dreamweaver, use Site>New Site to access 

Site Setup dialog box.
o Once the root folder is set, the file list in the 

Files panel acts as a file manager, allowing 
you to copy paste, delete, move, and open 
files just as you would on a desktop.

o This organizes all files associated with website 
including:
• Track and maintain links
• Manage files
• Transfer files to web server
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QUESTIONS TO CONSIDER
o Explain some rules to naming files for web 

design.
o What is the first thing you should do when 

creating a new website?
o What is the importance of a root folder?
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TEMPLATES
o A template is a special type of document that 

you use to design a “fixed” page layout; you 
can then use the web page to create a 
template that inherits its page layout. 

o Templates allow a Web designer to construct 
a site that
• Is flexible
• Easy to update, and 
• Consistent between HTML pages. 
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USING TEMPLATES
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USING TEMPLATES
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o Designers can make changes to the overall 
design of the site quickly by revising the 
.DWT files directly. 

o The pages that are linked to the template 
files are automatically updated allowing for 
site-wide modifications in minutes.

o Make sure not to move the .DWT file from the 
Templates folder. Do not rename or move the 
Templates folder. As long as the .DWT file 
remains inside the Templates folder, the links 
from the HTML pages to the template will not 
be broken.



QUESTIONS TO CONSIDER
o Why is it important for pages on the same 

website to use the same or similar templates?
o What information would you need prior to 

selecting or designing an appropriate 
template for a company?
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EDITABLE REGIONS
o As you design a template, you specify as 

“editable” which content users can edit in a 
document based on that template. 

o Selected content may be set as editable 
regions or an editable region may be inserted 
into the template.

o Editable regions enable template authors to 
control which page elements template 
users—such as writers, graphic artists, or 
other web developers—can edit.
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EDITABLE REGIONS
o You can create a template from an existing 

document or from a new document.
o As you work in the template, you can make 

changes to both editable and locked regions. 
o In a document based on the template, 

however, a template user can make changes 
only in the editable regions; the locked 
regions can’t be modified.

o This keeps the overall template design 
consistent across multiple pages.
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QUESTIONS TO CONSIDER
o Predict what could happen if a team of web 

designers were all able to change every part 
of a website under construction?

o What roles could you assign to different 
people so that each person was responsible 
for different aspects of the website?
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CREATE NEW WEB PAGE
o In Dreamweaver, use 

File>New to open 
New Document 
dialog box.

o Select the following:
• New Document
• Title
• Doc Type: HTML5
• Create

o Choose File>Save
• Check for root folder
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SET PAGE PROPERTIES
o You can specify layout and formatting 

properties for each page using the Page 
Properties dialog box.
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ADD CONTENT - TEXT
o You can type text directly in the Document 

window, or you can cut and paste text. You 
can also import text from other documents.

o Use the text Property Inspector to apply 
HTML formatting or Cascading Style Sheet 
(CSS) formatting.

o Select the text to be formatted before 
applying formatting change.
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GRAPHICS FOR WEB USE
o Graphics Optimization
• Design graphics with the specific purpose of using 

it on a website.
• Allows for quicker loading times.
• Adobe PhotoShop has save for Web or optimize 

options.
• Choose appropriate file format for web.
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ADD CONTENT - IMAGES
o In Dreamweaver, images may be inserted 

using a variety of commands.
o One such way is:
• Place insertion point where you want image.
• Select Insert>Image
• File will be copied to root folder (if not already 

there).
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IMAGES PROPERTY INSPECTOR
o The Images Property Inspector allows you to 

set properties for an image. If you do not see 
all options click the expander arrow in corner.

o Use the ALT area to add alternative text.
• Textual descriptions of graphics and other design 

components on a web page; aids in screen reader 
use for accessibility.
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Image Map
o A single graphic that is 

divided into sections 
and linked to different 
locations.  Example

Hotspot

o Specify a particular area 
as a link; can be drawn 
over a block of space, 
words, or an image.
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https://www.image-maps.com/maps/united_states/


QUESTIONS TO CONSIDER
o Explain some situations where an image map 

would be very useful.
o What is a hot spot in relation to an image 

map?
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Hyperlinks
o Clickable connections 

that link text or images 
to other pages of the 
website, out to external 
websites, or to files 
posted on a website.

Email Link (mailto)

o Does not link to an 
Internet location; causes 
the user’s computer to 
open the default email 
program and prepares a 
blank email to the 
specified address.
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ADD HYPERLINKS
o In the Properties Panel use the Link area to 

create a hypertext link of the selected text:
• Click the folder icon to browse to a file in your site.
• Type the URL.
• Drag the Point-To-File icon to a file in the Files 

panel
• Drag a file from the Files panel into the box.
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ADD HYPERLINK TARGETS
o In the Properties Panel use the Target area to 

specify the frame or window in which the 
linked document will load:
• _self -- opens in the same window and frame.
• _top -- opens in the same window, making the 

frame full size.
• _parent -- opens in the parent page’s frame.
• _blank -- opens in a new window and frame.
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ABSOLUTE LINK
o Contain a complete web address; always 

includes domain name of website.
o Great explanation here!  

http://www.coffeecup.com/help/articles/absol
ute-vs-relative-pathslinks/

o Absolute Path Examples
• http://www.mysite.com
• http://www.mysite.com/graphics/image.png

24

http://www.coffeecup.com/help/articles/absolute-vs-relative-pathslinks/


RELATIVE LINK
o Starts from the home page or root folder of 

the website and creates a path to the 
destination of the link.

o Relative Path Examples
• index.html
• /graphics/image.png
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QUESTIONS TO CONSIDER
o What hyperlink target is most likely to have 

the viewer return to the original website once 
they have clicked on the link? Why?

o Why would you want to make sure your 
viewer returns to your site after clicking a 
hyperlink?

o Why would you use an absolute link instead 
of a relative link? 
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DIV TAGS
o A tag that defines logical divisions within the 

content of a web page. 
o Use div tags to center blocks of content, 

create column effects, create different areas 
of color, and more.

o You can build page layouts by 
inserting div tags and applying CSS 
positioning styles. 

o This can be used instead of tables.
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USE DIV TAGS
o Place your insertion point where you want the 

div tag
o Use Insert>HTML>Div
o Select options and click OK.
o Add content to the div tag by placing your 

insertion point inside the tag, and then 
adding content.

o When you select a div tag, you can view and 
edit rules for it in the CSS Styles panel.
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ABSOLUTE VS RELATIVE DIV TAGS
o Absolute positioning (AP) allows you to place 

any page element exactly where you want it.
o AP elements’ positions will NOT adjust on the 

page according to the size of the browser 
window.

o Relative tag is "relative to itself".  Used with 
other positioning attributes will move from 
where it would NORMALLY be.

o Relative position can be used to align form 
elements, for example.
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ROLLOVER
o Feature that indicates interactivity to the user; 

normally causes a component of a web page 
to visually change when the user’s cursor 
hovers over it.

o Can be made in a graphic editing program or 
found online.  

o Need two images for each rollover.
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INSERT ROLLOVER
o Create a simple rollover effect with two 

images:
• Insert cursor where you want rollover.
• Choose Insert>HTML>Rollover Image.
• Give the rollover a name.
• Choose the original and rollover images.
• Add alternate text.
• Choose location.
• Click OK.
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INSERT NAVIGATION BAR
o Rollover buttons may be used to create 

navigation bars.
o Use the web design conventions of placing 

navigation bar:
• Horizontally across top of page
• Vertically on left side of page

o Be sure that buttons are consistent in size and 
color.
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LAYOUT DESIGN WITH TABLES
o Tables are a powerful tool for presenting 

tabular data and for laying out text and 
graphics on an HTML page.

o Using a table with specific size properties can 
ensure the page layout shows as designed.

o Cells, columns, and rows can be merged, split, 
resized, etc. the same as in other programs.

o Properties such as color, alignment, etc. can be 
applied to the table cells.

o In Dreamweaver, use Insert>Table to specify 
table settings.
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CREATE FORMS
o Web Form
• An interactive feature that allows a user to submit 

information. 

o Forms can be created within the web editor 
program.

o Or forms can be created using an external 
program such as Google Forms and linked to 
the page.

o Using a form editor is often easier and will 
include a database to collect the data.
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QUESTIONS TO CONSIDER
o On a shopping site, when it it essential to 

include a form?
o What other ways could a form be used on a 

website?
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USING MEDIA
o Media will not be visible in 

Design view, the file must be 
previewed in a browser to test 
media.

o Animated GIF’s
• Use the same process as inserting an 

image.

o Audio
• Insert audio files using Insert/HTML.
• Apply properties such as controls, 

autoplay or loop playback.
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USING MEDIA
o Video
• Video formats include .SWF, .FLV, .AVI, .MOV or 

.MPEG.
• May need plugin files for playback.
• Insert movie files using Insert/HTML.
• Apply properties such as skin, controls, autoplay or 

loop playback.

o All media files must be in root folder for 
proper playback.

o Or use YouTube/Vimeo to store video and 
link to page.
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QUESTIONS TO CONSIDER
o What alternative could a web designer use if 

they don’t want a video or audio file to play 
immediately when the page is opened?

o Predict what would happen if image, audio or 
video files are not saved in the root folder?

o What advantage does uploading a video to 
YouTube and then linking it have for the 
website?
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